Vollständige Version anzeigen : X11: cant open Display: schwarzer Bildschirm


unix
17.03.2013, 11:33

Hoi, wieder mal ein neues Problem bei mir =)

Mein neuer Laptop bleibt nach dem Booten einfach schwarz, ich komme nicht einmal zum Anmeldefenster.
Vorher seh ich noch alles, Grub und plymouth werden mir angezeigt und dann nix mehr.
Ich kann nichtmal auf die virtuellen Konsolen zugreifen.

Übers Netzwerk komme ich wenigstens noch dran und kann probieren nach dem Fehler zu suchen, finde aber leider keinen :)

"cat /var/log/Xorg;0;log | grep EE" gibt nur

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 11;907] (II) Loading extension MIT-SCREEN-SAVER

her, also keine Fehler oder so :(

Und xrandr --query sagt mir Cant open display.

In der Umgebungsvariable $DISPLAY steht nichts drin und eine Neuinstallation von xserver-xorg hat auch nichts gebracht.
Eine xorg;conf habe ich nicht gefunden (liegt doch normal unter /etc/X11/ ab)

Hab einen Grafikchip von Intel und ne Grafikkarte von Nvidia, wobei die Nvidia Graka noch gar nicht installiert wurde von mir (also noch keine Treiber dafür installiert).

Gestern ging es mal kurz, ich weiß nichtmal was ich genau gemacht hab, eig. nichts.

Hab das Teil angemacht und LAN angeschlossen, als ich dann vom 2. Lappi drauf wollte habe ich gesehen, dass das Anmeldefenster da ist -;-

Hab dann das Teil ein wenig genutzt gehabt und nach einem Neustart ging wieder nix.

Hat einer eine Idee? :)

Hardware Preisvergleich | Amazon Blitzangebote!

Videos zum Thema
Video Loading...
Crack02
17.03.2013, 11:57

modellbezeichnung laptop?
welche distro? version?


unix
17.03.2013, 12:30

ups, sorry.

Ist ein Lenovo U410 Ultrabook und ich hab Linux Mint Debian Edition drauf.


°EraZoR°
17.03.2013, 12:33

Installier doch mal die Treiber von nvidia;de..
Der Installer legt dann auch die passende xorg;conf an..


unix
17.03.2013, 13:20

Jou, habe ich auch schon versucht. Wenn ich die nvidia Treiber installiere, kommt so ein Einstellungsdialog, dass zuerst die nuevou Treiber in Konflikt stehen.

Dies wird aber angeblich nach einem Reboot beseitigt und dann kommt noch, dass die nvidia Treiber erst in der xorg;conf aktiviert werden müssen.

Auf meinem alten Laptop mit Linux Mint 14 gibts aber auch keine /etc/X11/xorg;conf und hier läuft alles.

Also auch mit den nvidia Treibern gehts nicht :(

Hab aber ein logfile gefunden mit paar Fehlern, aber die sagen eig. auch nicht mehr:
tail /root/;xsession-errors

Initializing caja-dropbox 0;7;1
Initializing caja-open-terminal extension
** Message: Initializing gksu extension...
mate-settings-daemon: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :1.
** Message: Got disconnected from the session message bus; retrying to reconnect every 10 seconds
mate-screensaver: Fatal IO error 11 (Die Ressource ist zur Zeit nicht verfügbar) on X server :1.
x-session-manager: Fatal IO error 0 (Erfolg) on X server :1.

(mate-panel:3666): Gtk-WARNING **: cannot open display: :1


Anscheinend kann der X-Server nicht korrekt starten oder so, weil der ja keine Bildschirme erkennt...


Mr. Mouse
17.03.2013, 13:24

Läuft das Teil mit NVIDIA Optimus Technologie?


unix
17.03.2013, 13:52

Läuft das Teil mit NVIDIA Optimus Technologie?

Anscheinend nicht, verbaut ist eine Geforce 610M und die ist bei wikipedia nicht in der Liste aufgeführt:
NVS 4200M
NVS 3100M
NVS 2100M
Quadro 5010M
Quadro 4000M
Quadro 3000M
Quadro 2000M
Quadro 1000M

(;de;wikipedia~org/wiki/Nvidia_Optimus)


Mr. Mouse
17.03.2013, 14:02

Scheint doch..

Despite the additional graphics card, the U410 still managed to last over seven and a half hours in our light use battery test – Nvidia’s Optimus graphics switching technology disables the GT 610M in favour of integrated graphics, meaning you don’t miss out on battery life compared to other Ultrabooks.

Versuch mal das hier:

sudo apt-get install ppa-purge
sudo apt-get purge bbswitch-dkms bumblebee-nvidia
sudo apt-get install linux-headers-generic
sudo apt-get install bbswitch-dkms bumblebee-nvidia

Reboot;


unix
17.03.2013, 14:37

ok, bumblebee gabs nicht in den Paketquellen bei mir, aber ich hab eine Anleitung gefunden und das Teil installiert, es läuft aber leider immernoch nicht:

(;suwako;nomanga~net/)

Ich bin über das wiki;debian auf die Seite geleitet worden.


Mr. Mouse
17.03.2013, 14:49

ok, bumblebee gabs nicht in den Paketquellen bei mir, aber ich hab eine Anleitung gefunden und das Teil installiert, es läuft aber leider immernoch nicht:

(;suwako;nomanga~net/)

Ich bin über das wiki;debian auf die Seite geleitet worden;


Wenn du Mint drauf hast, versuchs doch mal hiermit
Bumblebee › Hybrid-Grafikkarten › Wiki › ubuntuusers~de (;wiki;ubuntuusers~de/Hybrid-Grafikkarten/Bumblebee?redirect=no)


°EraZoR°
17.03.2013, 15:51

Um auf das Thema Nvidia-Treiber zurückzukommen..

Das mit der blacklist;conf, die der nvidia-installer anlegt, hat bei mir auch nie geklappt..
Entweder das Kernel-Modul direkt löschen oder das hier in die /etc/default/grub bei GRUB_CMDLINE_LINUX_DEFAULT anhängen:
modprobe;blacklist=nouveau

Dann nach dem Reboot die Installation nochmal durchführen..

Falls dann X11 immer noch nicht will, mal checken ob das Nvidia Modul geladen ist:
$ lsmod | grep nvidia


Die xorg;conf schreibst du übrigens mit:
# nvidia-xconfig

Wenn die nicht existiert wird sie angelegt..
X11 läuft auch ohne die xorg;conf..

Gruß
°EraZoR°


unix
17.03.2013, 17:58

Um auf das Thema Nvidia-Treiber zurückzukommen..

Das mit der blacklist;conf, die der nvidia-installer anlegt, hat bei mir auch nie geklappt..
Entweder das Kernel-Modul direkt löschen oder das hier in die /etc/default/grub bei GRUB_CMDLINE_LINUX_DEFAULT anhängen:
modprobe;blacklist=nouveau

Dann nach dem Reboot die Installation nochmal durchführen..

Falls dann X11 immer noch nicht will, mal checken ob das Nvidia Modul geladen ist:
$ lsmod | grep nvidia


Die xorg;conf schreibst du übrigens mit:
# nvidia-xconfig

Wenn die nicht existiert wird sie angelegt..
X11 läuft auch ohne die xorg;conf..

Gruß
°EraZoR°

Ich hab noch ein ganzes Image als Backup von gestern, kurz bevor es wieder einmal ging :D
Also habe jetzt diesen noveau Treiber geblacklistet und danach xserver-xorg-video-nvidia installiert, die Module sind geladen und mit nvidia-xconfig habe ich mir diese config erstellt:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 304;48 (pbuilder;cake) Wed Sep 12 10:54:51 UTC 2012

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28;0 - 33;0
VertRefresh 43;0 - 72;0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


Bildschirm ist immernoch schwarz und xrandr --query sagt auch noch Cant open Display :(

Aber vorher ging es doch auch schon ohne die Nvidia Treiber, sprich nur mit der Intel Grafik.


coach
18.03.2013, 17:52

also ich kenns von meinem desktop-pc, dass (solange das blacklisting nicht richtig funktioniert) die ausgabe _nur_ per igp, aber nie über die diskrete gpu ging..;mfg coach

PS: wieso hast du ansich screen :1 statt :0? und probier doch mal nur intel statt nur nvidia erstmal;)


Ähnliche Themen zu X11: cant open Display: schwarzer Bildschirm
  • [PC] Pes 09 Schwarzer bildschirm !?
    Habe mir heute pes 09 geholt und jetz gestartet und es kommen erstmal die sternchen und dann das konami und das wars... Schwarzer bildschirm Ich habe Windows vista Home edition 4 gb ram 2,0 dual Core 512mb Nvidia Karte (weis den namen nicht genau) Insgesamt habe ich einen notebook samsu [...]

  • [PC] WoW schwarzer bildschirm?! 0.o
    ich will auf einem privat server wow spielen und es klappt auch alles bis ich mir einen char erstellt habe und auf welt betretet klicke, dann laed er die map und wenn er fertig ist kriege ich nur einen schwarzen bildschirm und sehe nur meine maus, kann auch sonst nichts machen muss dann reset drueck [...]

  • Iphone schwarzer Display
    Hi, wollte heute mal iphone wiederherstellen, software konnte ich nicht neuaufspielen wegen dem Fehler3014. Dann habe ich mal das mit redsnow probiert und er hat auch die 3;1;2 draufgetan doch dann ist der Display aufeinmal schwarz geworden. Nun zeigt er nicht mehr an wenn ichd as iPhone an PC schli [...]

  • [Vista] Schwarzer Bildschirm am Display - Externer Monitor funktioniert
    Hey Leute... Also mein Notebook Display funktioniert nicht mehr... Ich habe meinen externen Bildschirm angeschlossen und dieser funktioniert einwandfrei.. Hin und wieder kommt auch das Bild am auf dem Notebookdisplay... Verschwindet aber nach 2 min oda mal 10 min ... Kommt mir so vor als hätt ich [...]



raid-rush.ws | Imprint & Contact pr