Vollständige Version anzeigen : Apache - NameVirtualHost *: 100% CPU load (PageSpeed)


toto1988
25.06.2013, 11:55

Hallo Community,

Ich habe vor ein paar Tagen Google PageSpeed Services getestet und seitdem habe ich Probleme mit meinem Apache. Die Installation von PageSpeed habe ich rückgängig gemacht aber irgendwo scheint noch was hängen geblieben zu sein!? Die CPU Auslastung ist dauerhaft bei 100% und die Logs gaben nicht wirklich was her.

Ich arbeite mit Debian Squeeze.


23428 mysql 20 0 1332m 402m 4416 S 38 5;2 2690:20 mysqld
3776 hartmann 20 0 219m 55m 8436 S 12 0;7 0:17;54 php5-cgi
3763 hartmann 20 0 219m 55m 8444 S 12 0;7 0:17;72 php5-cgi
3844 hartmann 20 0 217m 53m 8484 S 12 0;7 0:17;20 php5-cgi
3868 hartmann 20 0 223m 59m 8444 R 12 0;8 0:15;82 php5-cgi
3740 hartmann 20 0 219m 55m 8444 S 10 0;7 0:20;80 php5-cgi
3750 hartmann 20 0 221m 57m 8416 R 9 0;7 0:18;94 php5-cgi
3847 hartmann 20 0 217m 53m 8476 S 9 0;7 0:18;13 php5-cgi
3741 hartmann 20 0 219m 55m 8476 S 9 0;7 0:19;45 php5-cgi
3770 hartmann 20 0 221m 57m 8444 R 9 0;7 0:19;47 php5-cgi
3835 hartmann 20 0 222m 57m 8492 R 9 0;7 0:16;12 php5-cgi
3910 hartmann 20 0 221m 57m 8444 R 9 0;7 0:15;16 php5-cgi
3841 hartmann 20 0 217m 53m 8476 S 8 0;7 0:18;36 php5-cgi



Ich bin mittlerweile darauf gekommen, dass wenn ich die NameVirtualHost * Direktive aus der Konfig nehme, die Auslastung normal ist (maximal bei 2%). Sobald ich die Direktive wieder in die ports;conf eintrage, ist die Auslastung wieder bei 100%. Da ich aber mit Named Virtual Hosts arbeite, brauche ich die Direktive natürlich.

EDIT: Mir ist eben noch was komisches aufgefallen. Mit Joomla erstellte Seiten funktionieren ganz normal, aber Seiten die mit Wordpress erstellt wurden machen Probleme. Teilweise werden Sie extrem langsam aufgerufen oder es erscheint sogar ein 503 Error.

Ich hoffe ihr könnt mir weiterhelfen.

Danke
toto1988

Hardware Preisvergleich | Amazon Blitzangebote!

Videos zum Thema
Video Loading...
raid-rush
25.06.2013, 13:23

am besten die /etc/php5/php;ini mal hier posten - oder prüfen ob ganz am ende etwas angefügt wurde, falls ja entfernen.

ebenfalls die /etc/apache2/apache2;conf so wie die /etc/apache2/sites-enabled/default und andere einträge dort prüfen oder hier posten.

in der ports;conf sollte das stehen:

NameVirtualHost *:80
Listen 80


oder wenn du nicht viel configuriert hast und alles standart war, kannst du configs sichern und neu installieren

apt-get remove apache2 php5-cgi libapache2-mod-php5
apt-get install apache2 php5-cgi libapache2-mod-php5


falls du dir sicher bist alle configs gesichert zu haben oder keine zu benötigen, dann nutze apt-get remove --purge apache2 ..;usw damit werden die alten configs gelöscht.


toto1988
25.06.2013, 14:09

Hab nochmals in die ports;conf geschaut und dort stand nur

NameVirtualHost *
Listen 80


Nach der Änderung erhalte ich nun für alle TLD-Domains die Default Apache Seite --> It Works und für alle Unterseiten einen 404 Error

Ein Apache Neustart spuckt folgendes aus.



[Tue Jun 25 13:55:45 2013] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Tue Jun 25 13:55:45 2013] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Tue Jun 25 13:55:45 2013] [warn] NameVirtualHost *:80 has no VirtualHosts



Ein Vhost sieht so aus:

<VirtualHost *>
ServerName ;;toto1988~de
ServerAlias toto1988~de
ServerAdmin toto1988;web~de


DocumentRoot /var/;/tobias/public_html/
SuexecUserGroup toto1988 toto1988
<Directory /var/;/tobias/public_html/>
FCGIWrapper /var/;/tobias/conf ;php
<FilesMatch \;php$>
SetHandler fcgid-script
</FilesMatch>
Options +ExecCGI
Order allow,deny
allow from all
</Directory>

ErrorLog /var/log/apache2/error;log
LogLevel warn
CustomLog /var/log/apache2/access;log combined

</VirtualHost>


Ich habs auch mit <VirtualHost *:80> versucht.......

PS. Die Auslastung ist bei Null!


EDIT: Sobald ich irgendwo NameVirtualHost * reinbringe funktioniert zwar die Anzeige der Seiten aber die Serverauslastung ist bei 100%! Sobald ich NameVirtualHost entferne oder auf *:80 ändere funktionieren die Pages nicht mehr und die Auslastung ist bei 0.

Danke
toto1988


toto1988
25.06.2013, 21:21

So, jetzt bin ich ein paar Schritte weiter und ich konnte den Fehler ziemlich weit eingrenzen. Verursacher der hohen Auslastung war der SuexecUser von meinem Blog. Der Blog läuft unter Wordpress und ich habe im ersten Schritt alle Plugins deaktiviert, was leider keinen Erfolg brachte.

Jetzt bin ich soweit, dass ich zu Testzwecken einen anderen User in die VirtualHost Datei eingetragen habe, welcher keine Berechtigung hat. Die Auslastung geht nun wieder gegen 0, aber mein Blog funktioniert natürlich nicht nicht.

Jetzt hoffe ich, einer von euch kann mich weiter unterstützten bei der Suche nach der Ursache.

Danke
toto1988


Ähnliche Themen zu Apache - NameVirtualHost *: 100% CPU load (PageSpeed)
  • Wie funktioniert q-load.me?
    Hi Leute, wollte gerne nen 1,4gb film saugen den ich jedoch nur bei RS finde weil ich den selbe brauche und auch gerne für RR uppen würde. Bloß lohnt sich für 1,4gb kein Rs-acc ;) daher hab ich nach ner möglichkeit gesucht und q-load~me - de beste bron van informatie over q-load. Deze we [...]

  • all-load.to down ??
    die hatten doch schon letztens einen server umzug ! warte einfach was dann geht das schon wieder . Die hatten am anfang ja schon krasse probleme also vllt. wollen die die jetzt beheben . greetz BaboNo1 [...]

  • all-load.to
    Hi leutz tut mir wirklich sehr leid, wenn ich hier net richtich bin, aba ihr seid ja sowas wie parnter von der seite! Das Board von dennen geht momentan nich deshalb frag ich hier nach. Wenn ich auf dieSeite komm, dann kommt folgende Meldung (bei Firefox, Opra und IE6): Edit config;inc;php and upda [...]



raid-rush.ws | Imprint & Contact pr