Vollständige Version anzeigen : Samba Benutzer Konfiguration


unix
26.01.2014, 18:53

So mein erster Thread mit v4 :)

Habe aktuell ein Problem damit, einen schicken Samba4 Server aufzusetzen (nur für Dateifreigabe) und dann mit einem bestimmten User darauf zu zu greifen.

System schaut so aus:
Zum Test aktuell läuft alles grad in zwei VMs (eine Windows 7 Maschine zum Test und der eigentliche Server mit CentOS 6), beide im gleichen Subnet.

So aufm Server habe ich einen Benutzer
adduser --no-create-home --shell /bin/false user1
passwd user1
pdbedit -a -u user1

eingefügt. Linux User und Samba User haben das gleiche Passwort.
Dann füge ich den User in eine Gruppe smb_iv ein. Seit Samba4 werden die Benutzer anscheinend in nicht mehr der smbpasswd gespeichert
sondern in einer Datenbank deswegen pdbedit.

Den Share auf /public/iv/ivinstall ist von der Gruppe smb_iv und die Gruppe hat Lese und Schreibrechte (660). user1 ist ja Mitglied in der Gruppe smb_iv.

Also wenn man sich mit user1 auf dem Samba Server anmeldet sollte man ja Zugriff auf den Share haben?

Nun zu meiner smb;conf:

[global]
workgroup = FILEHOST
server string = SambaServer
netbios name = centos
passdb backend = tdbsam
log level = 2
#Drucker korrekt deaktivieren
printing = bsd
printcap name = /dev/null
map to guest = Bad User
username map = /etc/samba/smbusers
security = user

[ivinstall]
path = /public/iv/ivinstall
comment = Installationsdateien
available = yes
browseable = yes
guest ok = no
read only = no
force group = smb_iv


So, wenn ich mit dem Windows Rechner drauf will kommt beim Öffnen der Freigabe kommt folgendes im Logfile:

[2014/01/26 19:40:51;573899, 2] .;/source3/param/loadparm;c:3519(do_section)
Processing section "[ivinstall]"
[2014/01/26 19:41:05;066037, 2] .;/source3/smbd/smb2_server;c:3123(smbd_smb2_request_incoming)
smbd_smb2_request_incoming: client read error NT_STATUS_CONNECTION_DISCONNECTED
[2014/01/26 19:41:09;568111, 2] .;/source3/param/loadparm;c:3519(do_section)
Processing section "[ivinstall]"
[2014/01/26 19:41:09;569171, 2] .;/source3/auth/auth;c:288(auth_check_ntlm_password)
check_ntlm_password: Authentication for user [win7] -> [win7] FAILED with error NT_STATUS_NO_SUCH_USER
[2014/01/26 19:41:09;855510, 2] .;/source3/smbd/service;c:407(create_connection_session_info)
guest user (from session setup) not permitted to access this share (ivinstall)
[2014/01/26 19:41:09;855665, 1] .;/source3/smbd/service;c:584(make_connection_snum)
create_connection_session_info failed: NT_STATUS_ACCESS_DENIED
[2014/01/26 19:41:09;858297, 2] .;/source3/smbd/service;c:407(create_connection_session_info)
guest user (from session setup) not permitted to access this share (ivinstall)
[2014/01/26 19:41:09;858457, 1] .;/source3/smbd/service;c:584(make_connection_snum)
create_connection_session_info failed: NT_STATUS_ACCESS_DENIED

Zuerst will Windows mit dem ihn ihm eingeloggten Benutzer auf die Freigabe zugreifen, wird abgelehnt.
Dann kommt bei Windows das Fenster zum Einloggen für die Freigabe (Also username und password eingeben)

Wenn ich nun user1 und das Passwort von dem eintrage, komm die Meldung dass ich keine Berechtigung hätte für die Ressource.
im Log steht dann nur folgendes:
[2014/01/26 19:45:05;054392, 2] .;/source3/smbd/smb2_server;c:3123(smbd_smb2_request_incoming)
smbd_smb2_request_incoming: client read error NT_STATUS_CONNECTION_RESET
[2014/01/26 19:45:29;758406, 2] .;/source3/param/loadparm;c:3519(do_section)
Processing section "[ivinstall]"
[2014/01/26 19:45:29;765155, 2] .;/source3/auth/auth;c:278(auth_check_ntlm_password)
check_ntlm_password: authentication for user [user1] -> [user1] -> [user1] succeeded
[2014/01/26 19:45:29;776209, 1] .;/source3/smbd/service;c:891(make_connection_snum)
win7-pc (ipv4:192;168;178;26:49194) connect to service ivinstall initially as user user1 (uid=501, gid=500) (pid 1294)
[2014/01/26 19:45:49;353593, 2] .;/source3/smbd/server;c:436(remove_child_pid)
Could not find child 1295 -- ignoring


Sieht einer einen Fehler, wahrscheinlich hab ich einfach was durcheinander gebracht :)
Danke

Hardware Preisvergleich | Amazon Blitzangebote!

Videos zum Thema
Video Loading...
unix
27.01.2014, 19:51

Hab den Fehler heute gefunden.
Ich musste in der ACL des Shares noch die Gruppe smb_iv auf RW setzen. Dann hats geklappt.


Ähnliche Themen zu Samba Benutzer Konfiguration
  • [Signatur] Sig 4 Samba
    so hab mal ne sig 4 samba gemacht.;~da ich es ihm schon länger versprochen hatte und er ne anfrage aufgemacht hat, da dachte ich mir so machste mal eine :D...;also poste sie auch hier da ich mal wieder nen paar commis hören möchte nach ner längeren PS abstinenz ^^..;lange rede kurzer sinn 7727 [...]

  • samba problem
    Hallo wie der Titel schon sagt hab ich ein problem mit samba. hab in meiner smb;cfg im moment das drin stehen : [global] # --- Grundeinstellungen --- workgroup =ARBEITSGRUPPE netbios name = Char0n server string = SMB-Server %h (%v) socket options = TCP_NODELAY IPTOS_LOWDELAY \ [...]

  • Suche Samba für Win
    Hallo Leute, ich suche ein Prog mit dem ich wie bei Samba Seiten speichern kann und dann bei noch maligem Besuch di von dort geladen werden. Es muss LAN fähig sein sonst bringt es mir nix. Gibt es so was ?? Die portierte Version von Samba funzt bei mir ned! [...]

  • CentOs x64 Fail2ban Konfiguration und sslh konfiguration
    Hallo zusammen, so Server läuft alles schön. Nun wollte ich noch Fail2ban ein wenig gesprächiger machen und mir Mails schicken lassen etc.... Nur irgendwie will der driss nicht so wie ich will... Oder kennt wer eine gute Alternative? Kennt sich auch wer mit sslh aus? Hat irgendwer eine [...]



raid-rush.ws | Imprint & Contact pr